Security Advisory 2021-03

Summary Cleartext Storage of Sensitive Information in Octopus Server (CVE-2021-30183)
Advisory Number 2021-03
Discovery Date 07 Apr 2021
Patch Release Date 07 May 2021
Advisory Release Date 12 May 2021
Product Octopus Server
Operating System Windows
Severity Medium
CVE ID CVE-2021-30183

Customers who have downloaded and installed any of the Octopus Server versions listed below ("Details") are affected.

Please upgrade your Octopus Server immediately to fix this vulnerability.

Customers who have upgraded Octopus Server to version 2021.1.6959 or higher are not affected.

Severity

Octopus Deploy has given this vulnerability a medium rating. This rating was given according to the Octopus Deploy security levels, which ranks vulnerabilities as critical, high, medium, or low severity.

This is our assessment and you should evaluate its applicability to your own environment.

Details

When running migrator in Octopus Server, in certain situations when running import or export processes the password used to encrypt and decrypt sensitive values would be written to the logs in plaintext.

The versions of Octopus Server affected by this vulnerability are:

  • All 0.x.x, 1.x.x, 2.x.x, 3.x.x, 4.x.x versions

  • All 2018.x.x, 2019.x.x, 2020.1.x, 2020.2.x, 2020.3.x, 2020.4.x versions

  • All 2020.5.x versions before 2020.5.329

  • All 2020.6.x versions before 2020.6.4847

  • All 2021.1.x versions before 2021.1.6959

This issue can be tracked here: https://github.com/OctopusDeploy/Issues/issues/6875

Fix

To address this vulnerability, we have released Octopus Server version:

  • 2020.5.329

  • 2020.6.4847

  • 2021.1.6959

The latest versions of Octopus Deploy products can be downloaded from https://octopus.com/downloads and previous versions can be downloaded from https://octopus.com/downloads/previous

What You Need to Do

Octopus Deploy recommends that you upgrade to the latest version (2021.1.6959). You can download the latest version of Octopus Server from https://octopus.com/downloads

If you can't upgrade to the latest version (2021.1.6959):

If you have feature version... ...then upgrade to this version
2018.x.x, 2019.x.x, 2020.1.x, 2020.2.x, 2020.3.x, 2020.4.x 2020.5.329 or greater
2020.5.x 2020.5.329 or greater
2020.6.x 2020.6.4847 or greater

Mitigation

There is no known mitigation for CVE-2021-30183, it is important to upgrade to a fixed version as soon as possible.

Support

If you have any questions or concerns regarding this advisory, please contact our support team (https://octopus.com/support).

Exploitation and Public Announcements

The Octopus Deploy security team is not aware of any public announcements or malicious use of the vulnerability that is described in this advisory.

Source

This vulnerability was found by Octopus Deploy Engineering.