Security Advisory 2021-04

Summary SQL Injection in the Events REST API in Octopus Server (CVE-2021-31818)
Advisory Number 2021-04
Discovery Date 29 May 2021
Patch Release Date 10 Jun 2021
Advisory Release Date 10 Jun 2021
Product Octopus Server
Operating System Linux and Windows
Severity High
CVE ID CVE-2021-31818

Customers who have downloaded and installed any of the Octopus Server versions listed below ("Details") are affected.

Please upgrade your Octopus Server immediately to fix this vulnerability.

Customers who have upgraded Octopus Server to version 2021.1.7316 or higher are not affected.

Severity

Octopus Deploy has given this vulnerability a high rating. This rating was given according to the Octopus Deploy security levels, which ranks vulnerabilities as critical, high, medium, or low severity.

This is our assessment and you should evaluate its applicability to your own environment.

Details

Affected versions of Octopus Server are prone to an authenticated SQL injection vulnerability in the Events REST API because user supplied data in the API request isn’t parameterised correctly. Exploiting this vulnerability could allow unauthorised access to database tables.

The versions of Octopus Server affected by this vulnerability are:

  • All 2018.9.17, 2018.10.x, 2018.11.x, 2018.12.x versions

  • All 2019.x.x, 2020.1.x, 2020.2.x, 2020.3.x, 2020.4.x, 2020.5.x versions

  • All 2020.6.x versions before 2020.6.5146

  • All 2021.1.x versions before 2021.1.7316

Fix

To address this vulnerability, we have released Octopus Server versions:

  • 2020.6.5146

  • 2021.1.7316

The latest versions of Octopus Deploy products can be downloaded from https://octopus.com/downloads and previous versions can be downloaded from https://octopus.com/downloads/previous

What You Need to Do

Octopus Deploy recommends that you upgrade to the latest version (2021.1.7316). You can download the latest version of Octopus Server from https://octopus.com/downloads

If you can't upgrade to the latest version (2021.1.7316):

If you have feature version... ...then upgrade to this version
2018.9.17, 2018.10.x, 2018.11.x, 2018.12.x, 2019.x.x, 2020.1.x, 2020.2.x, 2020.3.x, 2020.4.x, 2020.5.x 2020.6.5146
2020.6.x 2020.6.5146
2021.1.x 2021.1.7316

Mitigation

If you are unable to patch your Octopus Server installations you can effectively mitigate this vulnerability by removing the EventView permission from roles. You can test which users have the EventView permissions by navigating to Configuration → Test Permissions and selecting a user from the drop down.

Although this mitigation is effective in preventing this vulnerability customers may experience some error messages when navigating to certain pages however, these errors do not prevent users from general use of the application. If this mitigation is used the audit log will not be accessible unless the user account has the EventView permissions, a link for further information about the audit log can be found below.

The following links provide further information for creating and managing roles, testing user permissions and audit log access:

Support

If you have any questions or concerns regarding this advisory, please contact our support team (https://octopus.com/support).

Exploitation and Public Announcements

The Octopus Deploy security team is not aware of any public announcements or malicious use of the vulnerability that is described in this advisory.

Source

This vulnerability was found by Justin Steven