Security Advisory 2022-02

Summary Open Redirect Vulnerability in Octopus Server (CVE-2022-23184)
Advisory Number 2022-02
Discovery Date 03 JAN 2022
Patch Release Date 14 JAN 2022
Advisory Release Date 19 JAN 2022
Product Octopus Server
Operating System Linux and Microsoft Windows
Severity Medium
CVE ID CVE-2022-23184

Customers who have downloaded and installed any of the Octopus Server versions listed below ("Details") are affected.

Please upgrade your Octopus Server immediately to fix this vulnerability.

Customers who have upgraded Octopus Server to version 2021.2.8011 or 2021.3.11057 and higher are not affected.

Severity

Octopus Deploy has given this vulnerability a medium rating. This rating was given according to the Octopus Deploy security levels, which ranks vulnerabilities as critical, high, medium, or low severity.

This is our assessment and you should evaluate its applicability to your own environment.

Details

In affected Octopus Server versions when the server HTTP and HTTPS bindings are configured to localhost, Octopus Server will allow open redirects.

The versions of Octopus Server affected by this vulnerability are:

  • All 0.x.x, 1.x.x, 2.x.x, 3.x.x, 4.x.x versions

  • All 2018.x.x, 2019.x.x, 2020.x.x, 2020.1.1 versions

  • All 2021.2.x versions before 2021.2.8011

  • All 2021.3.x versions before 2021.3.11057

Fix

To address this vulnerability, we have released Octopus Server versions:

  • 2021.2.8011

  • 2021.3.11057

The latest versions of Octopus Deploy products can be downloaded from https://octopus.com/downloads and previous versions can be downloaded from https://octopus.com/downloads/previous

What You Need to Do

Octopus Deploy recommends that you upgrade to the latest version (2021.3.11057). You can download the latest version of Octopus Server from https://octopus.com/downloads

If you can't upgrade to the latest version (2021.3.11057):

If you have feature version... ...then upgrade to this version
2018.x.x, 2019.x.x, 2020.x.x, 2020.1.1 2021.2.8011 or greater
2021.2.x 2021.2.8011 or greater
2021.3.x 2021.3.11057 or greater

For Octopus Server versions: 0.xx, 1.x.x, 2.x.x, 3.x.x, 4.x.x please contact our support team (https://octopus.com/support) for advice on upgrading to a supported version.

Mitigation

If you are unable to upgrade your Octopus Server installation you can effectively mitigate this vulnerability by removing the HTTPS binding and implement SSL offloading or by updating the HTTPS binding from localhost to match your DNS name.

Instructions for changing bindings using the GUI can be found here: https://octopus.com/docs/security/exposing-octopus/expose-the-octopus-web-portal-over-https#ExposetheOctopuswebportaloverHTTPS-Changingyourwebportalbindings

Instructions for changing bindings using the CLI can be found here: https://octopus.com/docs/octopus-rest-api/octopus.server.exe-command-line/configure

Support

If you have any questions or concerns regarding this advisory, please contact our support team (https://octopus.com/support).

Exploitation and Public Announcements

The Octopus Deploy security team is not aware of any public announcements or malicious use of the vulnerability that is described in this advisory.

Source

This vulnerability was found by https://bugcrowd.com/Elsfa7-110