Security Advisory 2022-18
|Summary||Sensitive value will only be partially masked when certain substrings exist in the set (CVE-2022-2720)|
|Discovery Date||08 Aug 2022|
|Patch Release Date||27 Sep 2022|
|Advisory Release Date||11 Oct 2022|
|Operating System||Linux and Microsoft Windows|
Customers who have downloaded and installed any of the Octopus Server versions listed below ("Details") are affected.
Please upgrade your Octopus Server immediately to fix this vulnerability.
Customers who have upgraded Octopus Server to version 2022.3.10594 or higher are not affected.
Octopus Deploy has given this vulnerability a medium rating. This rating was given according to the Octopus Deploy severity levels, which ranks vulnerabilities as critical, high, medium, or low severity.
This is our assessment and you should evaluate its applicability to your own environment.
In affected versions of Octopus Server it was identified that when a sensitive value is a substring of another value, sensitive value masking will only partially work.
The versions of Octopus Server affected by this vulnerability are:
- All 3.x versions after 3.16.4
- All 4.x versions
- All 2018.x, 2019.x, 2020.x and 2021.x versions
- All 2022.1.x versions before 2022.1.3154
- All 2022.2.x versions before 2022.2.7934
- All 2022.3.x versions before 2022.3.10586
To address this vulnerability, we have released Octopus Server version:
The latest versions of Octopus Deploy products can be downloaded from https://octopus.com/downloads and previous versions can be downloaded from https://octopus.com/downloads/previous
What You Need to Do
Octopus Deploy recommends that you upgrade to the latest version (2022.3.10594). You can download the latest version of Octopus Server from https://octopus.com/downloads
If you can't upgrade to the latest version (2022.3.10594):
|If you have feature version...||...then upgrade to this version|
|3.16.4 and greater||2022.1.3154 or greater|
|4.x, 2018.x, 2019.x, 2020.x, 2021.x||2022.1.3154 or greater|
|2022.1.x||2022.1.3154 or greater|
|2022.2.x||2022.2.7934 or greater|
|2022.3.x||2022.3.10586 or greater|
There is no known mitigation for CVE-2022-2720, it is important to upgrade to a fixed version as soon as possible.
If you have any questions or concerns regarding this advisory, please contact our support team https://octopus.com/support.
Exploitation and Public Announcements
The Octopus Deploy security team is not aware of any public announcements or malicious use of the vulnerability that is described in this advisory.
This vulnerability was found during internal testing by Adam Mccoy at Octopus Deploy