Security Advisory 2026-14
| Summary | Path Traversal in Octopus Server |
| Advisory Number | 2026-14 |
| Discovery Date | 14 JUN 2026 |
| Patch Release Date | 09 JUL 2026 |
| Advisory Release Date | 27 OCT 2026 |
| Product | Octopus Server |
| Operating System | Windows and Linux |
| Severity | Medium |
| CVE ID | CVE-2026-12887 |
Customers who have downloaded and installed any of the Octopus Server versions listed below ("Details") are affected.
Please upgrade your Octopus Server immediately to fix this vulnerability.
Customers who have upgraded Octopus Server to version 2026.3.15973 or higher are not affected.
Severity
Octopus Deploy has given this vulnerability a Medium rating. This rating was given according to the Octopus Deploy severity levels, which ranks vulnerabilities as critical, high, medium, or low severity.
This is our assessment and you should evaluate its applicability to your own environment.
Details
In affected versions of Octopus Server, a user with permission to upload a malicious nuget package is able to deploy a script step so the script executes outside of the parent directory.
The versions of Octopus Server affected by this vulnerability are:
- All 2023.x, 2024.x, 2025.x versions
- All 2026.1 versions before 2026.1.674
- All 2026.2 versions before 2026.2.973
- All 2026.3 versions before 2026.3.5839
Fix
To address this vulnerability, we have released Octopus Server version:
- 2026.1.674
- 2026.2.973
- 2026.3.5839
The latest versions of Octopus Deploy products can be downloaded from https://octopus.com/downloads and previous versions can be downloaded from https://octopus.com/downloads/previous
What You Need to Do
Octopus Deploy recommends that you upgrade to the latest version (2026.3.15973). You can download the latest version of Octopus Server from https://octopus.com/downloads
If you can't upgrade to the latest version (2026.3.15973):
| If you have feature version... | ...then upgrade to this version |
|---|---|
| 2019.x, 2020.x, 2021.x, 2022.x, 2023.x, 2024.x, 2025.x | 2026.1.674 or greater |
| 2026.1 | 2026.1.674 or greater |
| 2026.2 | 2026.2.973 or greater |
| 2026.3 | 2026.3.5839 or greater |
Mitigation
There is no known mitigation for CVE-2026-12887, it is important to upgrade to a fixed version as soon as possible.
Support
If you have any questions or concerns regarding this advisory, please contact our support team https://octopus.com/support.
Exploitation and Public Announcements
The Octopus Deploy security team is not aware of any public announcements or malicious use of the vulnerability that is described in this advisory.
Source
This vulnerability was found by siddharthkathole62bb60